About plug-ins

You can add various calendar conversion modules (plug-ins) to the program at any time. The only limitation to this point is that plug-in version should be same or earlier than the Calendar Wizard version. The program keeps track of plug-ins versions automatically.

Each plug-in settings are individual. You can run a plug-in by pressing the [Build] button.

Unregistered version of the software supports limited number of plug-ins.

Here is the list of existing plug-ins:

  • OLE Automation for CorelDRAW
  • Plain text
  • JPEG image
  • Hyper Text Markup Language (HTML)
  • Microsoft Excel


OLE Automation for CorelDRAW

This plug-in works as a direct CorelDraw commands manager. This works much like running the internal CorelDraw script except for the fact that using this plug-in takes way less time to create an image. It takes 2 to 20 minutes to create a calendar using this plug-in.

Before starting the creation job you must specify the CorelDraw version number. If a copy of CorelDraw is running it will be used for calendar creation purposes, if not Calendar Wizard will run the given version of CorelDraw.

In ver.2.3 there is capability to split items of days and the calendar grid lines into different layers. Each category in the calendar will be assigned its own layer. Example: a layer for the months, one for the days, one for the background boxes, one for the grid lines, etc. Moreover, there are options to merge all calendar days into the one layer and separate the grid lines into the single layer.


Adobe Portatable Document Format (PDF)

This plug-in creates files of Adobe PDF.

It's possible to select the following options:

Page size matches calendar size - if you check this option, the page size of documents matches to calendar size exactly, else page size is A4 (8,26x11,69 in) and the calendar is arranged in the centre.

Compressed format - compressed document has file size smaller than uncompressed one.

Include fonts - use that option to show fonts on other computers correctly. File size depends on that option.


Plain text

This plug-in lets you form the calendar as plain text file or save the data to clipboard. If Calendar Wizard will not be able to save data as actual plain text file the text will be copied to the clipboard instead.

You may use the following symbols as cell delimiters - tab (ANSI #9), space, or pipe ('|'). When using pipe or space as delimiters Calendar Wizard will put additional spaces in front of numbers ranging from 1 to 9 so that the text looks fine.

Tab: Space: Character "|":
 | January 2002
mo |  | 7 | 14 | 21 | 28
tu | 1 | 8 | 15 | 22 | 29
we | 2 | 9 | 16 | 23 | 30
th | 3 | 10 | 17 | 24 | 31
fr | 4 | 11 | 18 | 25 |
sa | 5 | 12 | 19 | 26 |
su | 6 | 13 | 20 | 27 |
January 2002
mo 7 14 21 28
tu 1 8 15 22 29
we 2 9 16 23 30
th 3 10 17 24 31
fr 4 11 18 25
sa 5 12 19 26
su 6 13 20 27
|January 2002|
mo| | 7|14|21|28
tu| 1| 8|15|22|29
we| 2| 9|16|23|30
th| 3|10|17|24|31
fr| 4|11|18|25|
sa| 5|12|19|26|
su| 6|13|20|27|


JPEG Image

When creating a JPEG image the following parameters influence the resulting image:

  • Image quality;
  • Color depth;
  • Resolution;
  • Use anti-aliased fonts

NOTE: keep in mind the fact that information on JPEG resolution is not saved in the file and all graphical editing software opens JPEGs with 72 dpi resolution. If you select different resolution we strongly recommend using the graphical software feature of 'changing image resolution without stretching\resizing image'.

If you specify .bmp as the image filename extension the image will be saved to Windows bitmap format.

Fonts anti-aliasing is not available under Windows 95.


HTML

Hyper Text Markup Language

This plug-in lets you create HTML-files that are web pages that can be placed on the Internet to represent on-line calendars.

You can specify whatever filename extension for generated HTML files.

Calendar layout is formed either by using CSS (Cascading Style Sheets) or alternative technology. When using CSS and style sheets are stored in external file the name of this file will be formed in the following pattern [<html-filename>.css].

CSS and No-CSS methods of generating html differ in resulting web page layout. This is mostly about the font size. Using CSS lets you specify the absolute value for the font size (measured in pixels or points) like in the following example:

.year { font-family: Arial; font-size: 14pt; font-weight: bold;  color: #00007F; text-align: center; }

Using the No-CSS method will result in relative font sizes, like:

<font color=#0000FF size=+2 face="Arial">

Browsers default font Size property is set to 3. Upon file generation fonts default to 10 pt. This value is omitted by default. All other parameters are provided using '+' or '-' values that represent the number of points to be added or subtracted to or from 10 pt. In the above example font size is set to 12.

Some browsers require HTML names and values to be placed into quotation marks. Specify the type of quotation marks used in process of generating HTML:

  • no quotation marks (example: color=#0000FF)
  • single (example: color='#0000FF');
  • double (example: color="#0000FF")

Holidays and observances may be laid out as web links. You can specify a custom template for hypertext link generation. Using the default template results in following: a link to January 1 will look like 1_1.html

You can choose the HTML encoding (US-ASCII, KOI8-r, and Windows-1251).


Microsoft Excel

This plug-in lets you form the calendar in Microsoft Excel format (any Excel version will do, including 95, 97, 2000, XP). You should have Microsoft Excel installed on your system to make this work since the calendar creation is conducted by Excel itself.

Due to the fact that Microsoft Excel uses it's own palette (color table) all colors used in your calendar will be adapted to this internal palette. The color adaptation procedure can be performed either by Excel or manually.

Click the color that needs to be changed ('MS Excel' column)

Windows clipboard is used when creating a new calendar. If you have any valuable data in clipboard you should save them before creating a calendar.

NOTE: earlier version of MS Excel (version 95) do not support cells adjoining which means you will have to center months names manually.